Timeout by access via Inxmail Home

Incident Report for Inxmail System

Resolved

The issue has been resolved. All systems are up and running
Posted Nov 06, 2025 - 10:10 CET

Monitoring

We have identified the issue and are seeing improvements on our infrastructure.
Our teams are continuing to monitore the situation.
Thank you for your patience
Posted Nov 06, 2025 - 09:48 CET

Investigating

We are currently experiencing some issue with Inxmail New Xperience or the Inxmail Platform when accessing via Inxmail Home.
Our technical teams are working on it and are hoping to resolve the problem swiftly.
If you require immidiate access to the mailing editor, please contact your account manager who will guide you through the process.

Inxmail Professional and Inxmail Commerce or Mail Relay are fully operational.
Posted Nov 06, 2025 - 09:20 CET
This incident affected: Newsletters & campaigns (Web interface).