Maintenance of our mailing editor exceeded timeslot
Incident Report for Inxmail System Status
Resolved
All system are back-up and operational.
Thank you for your patience.
Posted Apr 25, 2024 - 08:30 CEST
Update
We are continuing to investigate this issue.
Posted Apr 25, 2024 - 08:00 CEST
Investigating
We have identified a delay in the roll-out of our latest mailing editor.
The maintenance time may exceed the allocated timeslot.
Posted Apr 25, 2024 - 07:30 CEST
This incident affected: New Xperience (New Xperience).