Reduced performance on Inxmail Home

Incident Report for Inxmail System

Resolved

The issue has been resolved. The access and service and should be returning normal.
Thank you for your patience.
Posted Sep 11, 2025 - 11:05 CEST

Update

Our teams continue to work on resolving this issue.
We apologise for the inconvenience caused and thank you for your understanding.
Posted Sep 11, 2025 - 09:57 CEST

Identified

The root cause has been identified and a fix will soon be available.
Posted Sep 11, 2025 - 09:23 CEST

Investigating

We are currently experiencing some difficulties with Inxmail Home our portal to Inxmail Platform and Inxmail New Xperience. Our technical team have been informed and are working on resolving the situation swiftly. Thank you for your patience.
Posted Sep 11, 2025 - 09:22 CEST
This incident affected: Newsletters & campaigns (Web interface).