A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 15:49 CEST
Update
Microsoft has provided an update and is currently rolling out a solution. We should hopefully see improvements on the deferred queues once the deployment is completed.
Posted Sep 04, 2026 - 15:03 CEST
Update
Microsoft has confirmed that mailbox users may experience delays sending and receiving email messages from external domains in Microsoft Exchange. They are currently investigating to better understand the underlying cause and determine the most effective mitigation path
Posted Sep 04, 2026 - 13:43 CEST
Identified
We have been notified by several users and have confirmed that we are currently experiencing delivery issues to Microsoft 365. Unfortunately, this seems due to a potential outage on Microsofts end, which we cannot influence.
The sent emails are classified as deferred which means that they were successfully sent out from our infrastructures but have not reached the inbox of the recipient. New automatic delivery attempts will be made. First on a minute basis, then if unsuccessful in larger time intervals for up to maximum 5 days.
Please note other non-Microsoft Mailbox Providers are not impacted.